Observação
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Resumo
Este artigo fornece diretrizes sobre como resolver AADSTS50173 de código de erro ao tentar entrar em um aplicativo.
Sintomas
Quando os usuários tentam entrar em um aplicativo que usa a autenticação de ID do Microsoft Entra, eles recebem a seguinte mensagem de erro:
AADSTS50173: The provided grant has expired due to it being revoked, a fresh auth token is needed. The user might have changed or reset their password. The grant was issued on '{authTime}' and the TokensValidFrom date (before which tokens are not valid) for this user is '{validDate}'.
Motivo
Esse erro ocorrerá se o token de atualização usado para autenticação for revogado. Esse problema ocorre se:
- O usuário altera ou redefine sua senha.
- O token de atualização expira.
- Um administrador revoga o token de atualização.
Para saber mais, veja:
- Atualizar tokens na plataforma de identidade da Microsoft
- Revogar o acesso do usuário no Microsoft Entra ID
Solução
Para resolver esse problema, siga as etapas aplicáveis.
Para usuários
No aplicativo que apresenta os problemas, tente localizar uma opção para autenticar novamente ou limpar qualquer informação de token armazenada em cache. Você também pode executar essas ações saindo e entrando novamente no aplicativo (se esta etapa for aplicável ou estiver disponível).
Para desenvolvedores de aplicativos
Se o aplicativo estiver usando a MSAL (Biblioteca de Autenticação da Microsoft), siga estas diretrizes para lidar com erros e exceções na MSAL.
Se o aplicativo não estiver usando a MSAL, siga estas diretrizes para lidar com erros e exceções na MSAL e tente implementar uma abordagem semelhante no aplicativo. O objetivo é solicitar que o usuário se autentique novamente e obtenha um novo token.
Mais informações
Para obter uma lista completa de códigos de erro de autenticação e autorização, consulte Códigos de erro de autenticação e autorização do Microsoft Entra.
Para investigar erros individuais, vá para https://login.microsoftonline.com/error.