A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
1,412 questions with Microsoft Security | Microsoft Sentinel tags
CCF Data Connector – Pagination and Checkpoint handing with PageToken & PageStartTime
Hi Team, I am currently developing a custom Azure Sentinel Data Connector via the Common Connector Framework (CCF) for Google SecOps APIs. I am currently facing challenges related to pagination handling and state management for subsequent…
Microsoft Security | Microsoft Sentinel
Integrating AWS Security Hub into Microsoft Sentinel
Hello, I currently have Security Hub enabled in my AWS environment; however, the CloudWatch Logs are centralized for OU. Meaning, we have all of our logs automatically going to a Log Archive account for CW Logs. The issue is, in the CloudFormation…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Data lake configuration
Data lake creation fails with "Something went wrong" after multiple failed provisioning attempts. Microsoft.Kusto provider was not registered during initial attempts - now registered but the error persists. No orphaned ADX clusters found.…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Query Regarding Analytic Rule Limits in Microsoft Sentinel
I would like to understand the limitations and best practices related to analytic rules in Microsoft Sentinel. Specifically, I have the following queries: Is there a maximum limit on the number of analytic rules that can be kept active within a…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
We are experiencing an issue with the Cisco Meraki data connector in Microsoft Sentinel via API
We are experiencing an issue with the Cisco Meraki data connector in Microsoft Sentinel. The Meraki connector shows Disconnected / Not ingesting, and no security events are being retrieved from the Meraki REST API. Troubleshooting performed: Meraki MX…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Microsoft Sentinel cannot invoke playbook – missing required permissions despite correct IAM
We are encountering a Microsoft Sentinel automation/playbook execution failure. Error: "Failed to trigger playbook – Missing required permissions for Microsoft Sentinel on the playbook resource" Details: - Playbook is Logic App (Consumption) -…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Onboarding New clients data sources to my microsoft sentinel
we are running Microsoft sentinel and monitoring our internal data sources, now we want to Onboard New client's data sources to our Microsoft sentinel. Can you take me through this step by step how to do this by best practice. how can I segregate…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Azure Sentinel Data Connectors not consistent accross platforms
I noticed that data connectors list in Azure Powershell, Azure Portal and Defender portal are not consistent. Results I got from PowerShell (12 connectors) Defender Portal (3 connectors) Azure Portal (10 connectors) What is the most reliable way to…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
MS Sentinel Parsers - User account disable/enable events across local account and Entra contexts
I need an IM parser that can grab Event ID 4772 events, as well as grab "Enable account" operation events from the Azure AuditLog table. Does an out of the box parser exist for this use-case? I can see there's _Im_UserManagement parser for the…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
How to fix Microsoft Azure Sentinel to OCI issue , Codeless Connector deployment failed.
Microsoft Sentinel connector failed. Connectivity check failed. ConnectorId: oracle-cloud-infra-connector 63c27576-2a31-4993-9649-dd6fe2b01ce5, Status code:OCI40003
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
What do I use for the Identity provider for Microsoft Sentinel?
I've confirmed everything is configured in AWS, one a few concerns I have is the account ID in the trust policy role and as well as the openId connect. Is this the Identity provider i'm using for SSO with AWS? Or the one I use for Microsoft Sentinel?…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Sentinel Incident KQL
Hi, My exisiting KQL, here i want to include only hostname SecurityIncident | where CreatedTime between (datetime(2026-03-17) .. datetime(2026-03-23)) | where Status contains "Closed" | project IncidentNumber, LastModifiedTime, …
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Sophos Endpoint Protection Solution Azure App out of date
Having issues configuring the Sophos Endpoint Protection Solution marketplace app: https://marketplace.microsoft.com/en-us/product/azure-applications/azuresentinel.azure-sentinel-solution-sophosep Setup instructions are: STEP 1 - Configuration steps…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Missing Agent Management in Sentinel
My workspace is connected to my sentinel but when I look for the Workspace ID and keys there is nothing there. Can someone please let me know where I can find the workspace ID and Primary and secondary key that is used to connect my Linux rsyslog server.…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Sentinel Data Lake – Features unavailable for a specific workspace
I have a question regarding the configuration of the Sentinel Data Lake. A specific workspace does not appear under the following workspace scope in the Defender portal: Data lake exploration > KQL queries Could you tell me how to make it appear…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Sailpoint Identity function failure
Hi Everyone, We have used the built in Sentinel Data connector for Sailpoint IdentityNow. The Sailpoint team have confirmed they followed the access token steps provided in the data connector. We have successfully deployed it with the client ID, secret…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
How to fix StreamID must be a valid OCI stream OCID format. This is related to the oracle cloud infrastructure data connector.
I am sending Oracle Audit logs to Azure Sentinel. But i am getting the validation error "StreamID must be a valid OCI stream OCID format" while entering on the details on the connector page. I think the problem is that the connector does not…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Intermittent "Missing Heartbeat" Alerts in Sentinel Even Though Logs Show No Gap
Hi everyone, I have an on-premises virtual machine onboarded to Azure Arc and I’m collecting Heartbeat logs using the Azure Monitor Agent (AMA) in Microsoft Sentinel. I created an analytics rule to trigger an alert if a heartbeat is missing for 10…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
how to properly parse data in custom logs for log analytcis(i have no response from query actually) ?
I have some data, in a txt file. i create my txt with a powershell script who encode in utf8, but anything work when i import the log in log analytics. the data is parse like this in the txt: Time=Date Data1=data Data2=data2 Time=Date Data1=data…
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems
Azure Monitor Agent-DCR custom path template for filtering Database logs
Hi There! I would like to filter out Database logs using Azure Monitor Agent DCR by custom x-path queries. Is there any readymade x-path queries available to filter the audit logs of Oracle DB, MSSQL DB and MYSQL DB? Thanks in Advance!
Microsoft Security | Microsoft Sentinel
A cloud-native SIEM solution that provides intelligent security analytics and threat detection across systems